Tuesday, March 04, 2008

Using Mac will make you 'dumb' 'dull', using Windows will just waste your time.


Yes, if you spend too much time using Mac, you'll eventually become 'dumb' 'dull' in technical troubleshooting sense of way. You've taken by granted that everything in Mac will just work.

Yesterday's evening, my brother in law called me. He signed up for Speedy ADSL service. The technician came by to install the modem. He tested it using his notebook (with XP) and worked with no problem. Then he tried to connect the modem to my bro's Vista. It didn't work. In my conversation with the technician, he said that he got no experience with Vista, thus didn't know how to troubleshoot the problem. It is suppose to be plug and pray right? The ethernet suppose to automatically get an address from the modem. Apparently it didn't work.

So I have to drive to his house, 20 minutes away. When I arrived, the technician was quite confused, as also it's already 8pm, and I don't think he is being paid overtime. I told the tech guy to leave, since he proofed that the internet is working using his notebook.

I started tweaking with the network setting in Vista. Automatic addressing, didn't work. Manual address, didn't work. Strangely I saw 2 'network connections'. One being the ethernet port itself, and the other was 'unidentified network'. What the heck. Did Vista has new network feature that I didn't know about?

Darn, I didn't bring my Powerbook with me. So I had to drive back home, bring my PowerBook over. I plugged in my PowerBook, and whoala! it worked!

I started tweaking with Vista network setting again. A strange sign was when I ipconfig, in the gateway there's 2 entries. They are '0.0.0.0' and '192.168.1.1'.
It was suppose to be only 1, which is the 192.168.1.1.
I go to the TCP/IP prop, go to Advance and check the gateway entries, nothing there.

Diagnosting and Repair feature didn't help, but wasting my time.

Finally, I tried to reenter the IP address info manually, including entering several fake gateway addresses, click Apply, and then erase them, and click Apply. Set to automatic, and whoala! it works! The 0.0.0.0 was gone!

So, because I am using too much Mac, I become dumb dull. It should't took that much time to troubleshoot this problem. I begin to loose my troubleshooting skills and feeling, because aint much to troubeshoot in Mac.
Because my brother in law use Vista, he wasted my whole evening, just for this silly problem.

[update : the very next day]
Aparently the problem reappeared the very next day. Darn! If it can't established a network connection due to "unindentified network" problem, then I can't connect to internet and google. Disable, enable, and restarted several times, and on one lucky shot, it connected to the ADSL modem. I quickly google for this problem, and whoala! we are not alone! And there's no single solution for this problem, as nobody for sure knows what caused it (including those MS MVPs).
One of the most possible solution is to download Norton Removal Tool link. The notebook came with Symantec Internet Security preinstalled.
[Tips from lockergnome.com
I downloaded it, and run it TWICE just to make sure. Restart the notebook and it connected after reboot. The problem went away, or did it?

[update : the next day]
Aparently it didn't go away. So I recheck everything again. Run Norton Removal Tool again, uninstalling unneeded programs, and updating the network driver. It didn't work. However, I notice that if the modem is on before I TURN ON the notebook, then the notebook can connect to the modem, but if the notebook is on before the modem, then it will goes into "unidentified network" status, and can't connect.

SOLUTION : Turn on the modem, wait for 1 minutes, then turn on the notebook.

MORAL : Using Vista is just a waste of time. You'll most likely end up troubleshooting for something that suppose to work. You'll loose your precious time. You better stick with XP or use Mac OSX.

image credit : http://www.gameshout.com/news/windows_home_server_bug_causes_problems1/article9922.htm

1 comment:

Gimson said...

lucky for your brother in law, he didn't need to buy a brand new mac with leopard